New Video posted 8-18-18

Post Reply
User avatar
goldstud
Site Admin
Posts:550
Joined:Wed Feb 28, 2018 2:42 am
Contact:
New Video posted 8-18-18

Post by goldstud » Mon Aug 20, 2018 2:06 am

New video posted in the section

Crump mounted/ open end

goldstudservices.com/wp-content/uploads/_mediavault/2018/arte%20urethral%20pulse%20attempts.mp4

Shassha
Posts:100
Joined:Thu Mar 01, 2018 1:43 pm
Contact:

Re: New Video posted 8-18-18

Post by Shassha » Mon Aug 20, 2018 4:33 am

Well, an attempt was made!
I hope the cameras are all okay.

Dingoz
Posts:98
Joined:Tue Mar 06, 2018 11:05 pm
Contact:

Re: New Video posted 8-18-18

Post by Dingoz » Mon Aug 20, 2018 4:35 pm

Well that didnt show much, the camera is usually better when you are alone even. Also I must say ive had issues with the site the last couple of days. Its very slow at times and the videos is a pain to watch because of slow loading or error messages. I have never had any issues like this before.

harvclub
Posts:130
Joined:Sun Mar 04, 2018 5:14 am
Contact:

Re: New Video posted 8-18-18

Post by harvclub » Mon Aug 20, 2018 6:44 pm

Glad the new help arrived! Hopefully they're fitting in well.

Good first effort, a little too close to see much but hopefully with a bit of practice you'll both get the shots you need.
Good luck!

Shassha
Posts:100
Joined:Thu Mar 01, 2018 1:43 pm
Contact:

Re: New Video posted 8-18-18

Post by Shassha » Tue Aug 21, 2018 3:27 am

Dingoz wrote:
Mon Aug 20, 2018 4:35 pm
Well that didnt show much, the camera is usually better when you are alone even. Also I must say ive had issues with the site the last couple of days. Its very slow at times and the videos is a pain to watch because of slow loading or error messages. I have never had any issues like this before.
I believe the issues stem from external download flooding, something they are trying to fix on the site.

User avatar
goldstud
Site Admin
Posts:550
Joined:Wed Feb 28, 2018 2:42 am
Contact:

Re: New Video posted 8-18-18

Post by goldstud » Tue Aug 21, 2018 6:08 am

Dingoz wrote:
Mon Aug 20, 2018 4:35 pm
Well that didnt show much, the camera is usually better when you are alone even. Also I must say ive had issues with the site the last couple of days. Its very slow at times and the videos is a pain to watch because of slow loading or error messages. I have never had any issues like this before.
I am not sure why some people are having issues and others are not. What browser is everyone using?

User avatar
goldstud
Site Admin
Posts:550
Joined:Wed Feb 28, 2018 2:42 am
Contact:

Re: New Video posted 8-18-18

Post by goldstud » Tue Aug 21, 2018 6:09 am

Shassha wrote:
Tue Aug 21, 2018 3:27 am
Dingoz wrote:
Mon Aug 20, 2018 4:35 pm
Well that didnt show much, the camera is usually better when you are alone even. Also I must say ive had issues with the site the last couple of days. Its very slow at times and the videos is a pain to watch because of slow loading or error messages. I have never had any issues like this before.
I believe the issues stem from external download flooding, something they are trying to fix on the site.
Yes. That has been an issue. We are trying to fix it but wordpress is not making it easy!

harvclub
Posts:130
Joined:Sun Mar 04, 2018 5:14 am
Contact:

Re: New Video posted 8-18-18

Post by harvclub » Tue Aug 21, 2018 11:57 am

I had a thought of how you might be able to see the urethral pulses a bit better, though it might be a bit more difficult.

I've noticed that the pulses are more noticeable in the area between the medial ring and the glans, what if you allowed your stud to mount a female but used one of those breeder rolls to space him out a bit, ensuring that only his glans entered her. If he's teased enough, perhaps the heat, pressure and excitement of an actual female will be enough to make him ejaculate. I know it's not ideal for actual breeding as most of the semen will be entering her rather shallow (Or escaping all together) but it might allow for a good side angle. If pressure is a concern you could also use one of the studs that reacted well to the pressure of a condom and have it just cover his glans, not the rest of the shaft, keeping it clear to the view point.

Just a random idea!

airion
Posts:35
Joined:Thu Mar 01, 2018 2:14 am
Contact:

Re: New Video posted 8-18-18

Post by airion » Tue Aug 21, 2018 2:52 pm

I'm using Chrome, and never have any problems.

Kam
Posts:17
Joined:Wed Mar 14, 2018 12:28 am
Contact:

Re: New Video posted 8-18-18

Post by Kam » Tue Aug 21, 2018 9:28 pm

I've been able to view them just fine, though it has been slower. I understand that it is being worked on, and I hope you're able to fix it! I'm using Chrome, by the way.

User avatar
goldstud
Site Admin
Posts:550
Joined:Wed Feb 28, 2018 2:42 am
Contact:

Re: New Video posted 8-18-18

Post by goldstud » Wed Aug 22, 2018 6:17 am

harvclub wrote:
Tue Aug 21, 2018 11:57 am
I had a thought of how you might be able to see the urethral pulses a bit better, though it might be a bit more difficult.

I've noticed that the pulses are more noticeable in the area between the medial ring and the glans, what if you allowed your stud to mount a female but used one of those breeder rolls to space him out a bit, ensuring that only his glans entered her. If he's teased enough, perhaps the heat, pressure and excitement of an actual female will be enough to make him ejaculate. I know it's not ideal for actual breeding as most of the semen will be entering her rather shallow (Or escaping all together) but it might allow for a good side angle. If pressure is a concern you could also use one of the studs that reacted well to the pressure of a condom and have it just cover his glans, not the rest of the shaft, keeping it clear to the view point.

Just a random idea!
You are correct about where the pulses are most visible. It is just hard to video that area while my arm is in the way to stimulate the stallion.

Unfortunately, allowing him to mount a mare live is just not realistic at this time. It would require to have a mare willing to stand as well as having even more people available to do the handling of stallion, mare and filming.

Dingoz
Posts:98
Joined:Tue Mar 06, 2018 11:05 pm
Contact:

Re: New Video posted 8-18-18

Post by Dingoz » Wed Aug 22, 2018 6:52 pm

Maybe now when you have more help you can feature some of the stallions who are further away on your property too if possible.

User avatar
goldstud
Site Admin
Posts:550
Joined:Wed Feb 28, 2018 2:42 am
Contact:

Re: New Video posted 8-18-18

Post by goldstud » Thu Aug 23, 2018 1:12 am

Dingoz wrote:
Wed Aug 22, 2018 6:52 pm
Maybe now when you have more help you can feature some of the stallions who are further away on your property too if possible.
I fully intend to. I also need to start collecting them anyway because I need to freeze semen on everyone

Dingoz
Posts:98
Joined:Tue Mar 06, 2018 11:05 pm
Contact:

Re: New Video posted 8-18-18

Post by Dingoz » Thu Aug 23, 2018 5:34 pm

Cool! By the way, after some investigating I found that I have no problem watching your "older" videos in the other categories but the problem is the recent videos in ground open ended category. I can hardly watch any of those at the moment. Ive tried both chrome and firefox. Its been like that for some days, before that there was no problem for me at least.

User avatar
goldstud
Site Admin
Posts:550
Joined:Wed Feb 28, 2018 2:42 am
Contact:

Re: New Video posted 8-18-18

Post by goldstud » Thu Aug 23, 2018 6:19 pm

Dingoz wrote:
Thu Aug 23, 2018 5:34 pm
Cool! By the way, after some investigating I found that I have no problem watching your "older" videos in the other categories but the problem is the recent videos in ground open ended category. I can hardly watch any of those at the moment. Ive tried both chrome and firefox. Its been like that for some days, before that there was no problem for me at least.
Interesting

Aaron2193
Posts:86
Joined:Sun Mar 04, 2018 6:28 pm
Contact:

Re: New Video posted 8-18-18

Post by Aaron2193 » Thu Aug 23, 2018 9:10 pm

Yes it's the same for me. I was about to post this same exact thing. I run chrome. It's the same for my laptop and my phone.

Socomuser1
Posts:14
Joined:Sat Mar 24, 2018 2:58 am
Contact:

Re: New Video posted 8-18-18

Post by Socomuser1 » Mon Aug 27, 2018 4:58 am

im having trouble viewing this video as well. chrome firefox and edge. idk why

User avatar
goldstud
Site Admin
Posts:550
Joined:Wed Feb 28, 2018 2:42 am
Contact:

Re: New Video posted 8-18-18

Post by goldstud » Mon Aug 27, 2018 1:32 pm

Socomuser1 wrote:
Mon Aug 27, 2018 4:58 am
im having trouble viewing this video as well. chrome firefox and edge. idk why
Try the new posted video and let me know if it works. If so then I know what is going on with the others. The new one is the last one on this page.

http://goldstudservices.com/crump-mounted-open-end-2/

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest